using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w)[_]{1,1}([a-z]{1,1})).+?(?=\:)";
string substitution = @"$1\U$2";
string input = @"{
""@version"": ""1"",
""point_altitude"": 530,
""equipment_id"": ""3325"",
""header"": {
""raw_message"": "",
""message_type_id"": ""ping_event""
}
}
.+?(?=\:)
(?<=,|{)"".+?""\s?(?=:)
""(?:\\.|[^""\\])*""(?=\s*:)
(\w)[_]{1,1}([a-z])
(.*?)_([a-zA-Z])";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}