$re = '/((\w)[_]{1,1}([a-z]{1,1})).+?(?=\:)/';
$str = '{
"@version": "1",
"point_altitude": 530,
"equipment_id": "3325",
"header": {
"raw_message": "",
"message_type_id": "ping_event"
}
}
.+?(?=\\:)
(?<=,|{)".+?"\\s?(?=:)
"(?:\\\\.|[^"\\\\])*"(?=\\s*:)
(\\w)[_]{1,1}([a-z])
(.*?)_([a-zA-Z])';
$subst = "$1\U$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;