import Foundation
let pattern = #"((\w)[_]{1,1}([a-z]{1,1})).+?(?=\:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"@version": "1",
"point_altitude": 530,
"equipment_id": "3325",
"header": {
"raw_message": "",
"message_type_id": "ping_event"
}
}
.+?(?=\:)
(?<=,|{)".+?"\s?(?=:)
"(?:\\.|[^"\\])*"(?=\s*:)
(\w)[_]{1,1}([a-z])
(.*?)_([a-zA-Z])
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\U$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)