using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=Scenario).+?\bdog\b.+?(?=Scenario|$)";
string input = @"Scenario: lady swallows fly Given a lady and lady swallows a ""fly"" then lady lives
Scenario: lady swallows spider Givendoga a lady and lady swallows a ""fly"",""spider"" then lady lives
Scenario: lady swallows everything Given a lady and lady swallows a ""fly"",""spider"",""cat"",""dog"",""cow"" then badog lady Dies Scenario: lady swallows fly Given a lady and lady swallows a ""fly"" then lady lives
Scenario: lady swallows spider Given a lady and lady swallows a ""fly"",""spider"" then lady lives
Scenario: lady swallows everything Given a lady and lady swallows a ""fly"",""spider"",""cat"",""dog"",""cow"" then lady Dies";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}