import re
regex = re.compile(r"(?=Scenario).+?\bdog\b.+?(?=Scenario|$)", flags=re.MULTILINE)
test_str = ("Scenario: lady swallows fly Given a lady and lady swallows a \"fly\" then lady lives\n\n"
"Scenario: lady swallows spider Givendoga a lady and lady swallows a \"fly\",\"spider\" then lady lives\n\n"
"Scenario: lady swallows everything Given a lady and lady swallows a \"fly\",\"spider\",\"cat\",\"dog\",\"cow\" then badog lady Dies Scenario: lady swallows fly Given a lady and lady swallows a \"fly\" then lady lives\n\n"
"Scenario: lady swallows spider Given a lady and lady swallows a \"fly\",\"spider\" then lady lives\n\n"
"Scenario: lady swallows everything Given a lady and lady swallows a \"fly\",\"spider\",\"cat\",\"dog\",\"cow\" then lady Dies")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")