#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\n]+\bdog\b[^\n]+"
Local $sString = "Scenario: lady swallows fly Given a lady and lady swallows a "fly" then lady lives" & @CRLF & _
"" & @CRLF & _
"Scenario: lady swallows spider Given a lady and lady swallows a "fly","spider" then lady lives" & @CRLF & _
"" & @CRLF & _
"Scenario: lady swallows everything Given a lady and lady swallows a "fly","spider","cat","dog","cow" then lady Dies"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")