package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\n]+\bdog\b[^\n]+`)
var str = `Scenario: lady swallows fly Given a lady and lady swallows a "fly" then lady lives
Scenario: lady swallows spider Given a lady and lady swallows a "fly","spider" then lady lives
Scenario: lady swallows everything Given a lady and lady swallows a "fly","spider","cat","dog","cow" then lady Dies`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}