// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\n]+\bdog\b[^\n]+").unwrap();
let string = "Scenario: lady swallows fly Given a lady and lady swallows a \"fly\" then lady lives
Scenario: lady swallows spider Given a lady and lady swallows a \"fly\",\"spider\" then lady lives
Scenario: lady swallows everything Given a lady and lady swallows a \"fly\",\"spider\",\"cat\",\"dog\",\"cow\" then lady Dies";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}