const regex = /^[^\n]+\b| 123321 |\b[^\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n]+\\b| 123321 |\\b[^\\n]+', 'gm')
const str = `Scenario: lady swallows fly Given a lady and lady swallows a "fly" then lady lives
Scenario: lady swallows spider Given a lady and lady swallows a "fly","spider" then lady lives
Scenario: lady swallows everything Given a lady and lady swallows a "fly","spider","cat","dog","cow" then lady Dies
Examples:
| passcode | confirmPasscode | passcode_old | confirmPasscode_old |
| 456654 | 456654 | 123321 | 123321 |
####################################################### Validation of Copytext change on invalid memorable word screen ###################################################################################################
#Change History :
#24/07/2018 - Test created for AS2 Optimization project | Sakshi Saxena |
#21/08/2018 - Dry Run | Sakshi Saxena |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}