import Foundation
let pattern = #"^[^\n]+\b| 123321 |\b[^\n]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####################################################################################################"""
Scenario: lady swallows fly Given a lady and lady swallows a "fly" then lady lives
Scenario: lady swallows spider Given a lady and lady swallows a "fly","spider" then lady lives
Scenario: lady swallows everything Given a lady and lady swallows a "fly","spider","cat","dog","cow" then lady Dies
Examples:
| passcode | confirmPasscode | passcode_old | confirmPasscode_old |
| 456654 | 456654 | 123321 | 123321 |
####################################################### Validation of Copytext change on invalid memorable word screen ###################################################################################################
#Change History :
#24/07/2018 - Test created for AS2 Optimization project | Sakshi Saxena |
#21/08/2018 - Dry Run | Sakshi Saxena |
"""####################################################################################################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)