using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/my\.matterport\.com\/show\/\??(m=(?<code>[\w\d]+))";
string input = @"https://my.matterport.com/show/?m=kiVrPJ4GLGF&brand=0&ts=2
https://my.matterport.com/show/?m=8QLBuW5dxqB&brand=0&ts=3&help=1
https://my.matterport.com/show/?m=vycyVs9Xe9W";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}