import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(SbbE(?=(?:.{4}){0,2}(?:StbE){2}|(?:.{4})?StbE.{4}StbE|StbE.{8}StbE).{16}(?!StbE).{4}))";
final String string = "SbbESbbESbbEStbEStbESbbEStbESttE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}