re = /(?=(SbbE(?=(?:.{4}){0,2}(?:StbE){2}|(?:.{4})?StbE.{4}StbE|StbE.{8}StbE).{16}(?!StbE).{4}))/m
str = 'SbbESbbESbbEStbEStbESbbEStbESttE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end