const regex = new RegExp('(?=(SbbE(?=(?:.{4}){0,2}(?:StbE){2}|(?:.{4})?StbE.{4}StbE|StbE.{8}StbE).{16}(?!StbE).{4}))', 'gm')
const str = `SbbESbbESbbEStbEStbESbbEStbESttE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}