import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/posts\\/(?<slug>.+\\-)?(?<id>\\w+)$";
final String string = "/posts/going-long-for-the-ball-3a6p412\n"
+ "/posts/3a6p412\n"
+ "/posts/-3a6p412\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}