$re = '/\/posts\/(?<slug>.+\-)?(?<id>\w+)$/m';
$str = '/posts/going-long-for-the-ball-3a6p412
/posts/3a6p412
/posts/-3a6p412
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);