const regex = /\/posts\/(?<slug>.+\-)?(?<id>\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/posts\\\/(?<slug>.+\\-)?(?<id>\\w+)$', 'gm')
const str = `/posts/going-long-for-the-ball-3a6p412
/posts/3a6p412
/posts/-3a6p412
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}