const regex = /^([^.])+(?=\.)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^.])+(?=\\.)', 'mg')
const str = `......... A
1........ B
112...... C
11111.... D
1111113.. E
111111111 F
111111111 G`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}