$re = '/^([^.])+(?=\.)/m';
$str = '......... A
1........ B
112...... C
11111.... D
1111113.. E
111111111 F
111111111 G';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);