re = /^([^.])+(?=\.)/m
str = '......... A
1........ B
112...... C
11111.... D
1111113.. E
111111111 F
111111111 G'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end