using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(=|\+|-|:)+";
string substitution = @"_";
string input = @"==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}