re = /(=|\+|-|:)+/
str = '==GFTX=BL2++UMB01+MPDP01+00010-PIO01:04'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result