use strict;
my $str = 'GHI/GHI';
my $regex = qr/((\w+)(?=\/\2))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";