$re = '/((\w+)(?=\/\2))/m';
$str = 'GHI/GHI';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;