import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">([^<]*)<\\/";
final String string = "<td style=\"text-align: center;\">31</td><td style=\"text-align: center;\">14</td><td style=\"text-align: center;\">opened</td><td style=\"text-align: center;\">receiver</td><td style=\"text-align: center;\">elro_800_contact</td><td style=\"text-align: center;\">0000-e8-de-27-176d10</td><td style=\"text-align: center;\">6</td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}