// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r">([^<]*)<\/").unwrap();
let string = "<td style=\"text-align: center;\">31</td><td style=\"text-align: center;\">14</td><td style=\"text-align: center;\">opened</td><td style=\"text-align: center;\">receiver</td><td style=\"text-align: center;\">elro_800_contact</td><td style=\"text-align: center;\">0000-e8-de-27-176d10</td><td style=\"text-align: center;\">6</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}