#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([1-9]\d*)-(0[1-9]|1[0-2])-(0?[1-9]|[1-2]\d|3[0-2])(?:\x20([01][0-9]|2[0-3]):([0-5]\d):([0-5]\d)(\.\d+)?)?$"
Local $sString = "2015-03-32 07:00:00" & @CRLF & _
"2015-05-15 12:00:54.02911"
Local $sSubst = "year: $1, month: $2, day: $3, hours: $4, minutes: $5, seconds: $6$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)