import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d*)-(0[1-9]|1[0-2])-(0?[1-9]|[1-2]\\d|3[0-2])(?:\\x20([01][0-9]|2[0-3]):([0-5]\\d):([0-5]\\d)(\\.\\d+)?)?$";
final String string = "2015-03-32 07:00:00\n"
+ "2015-05-15 12:00:54.02911";
final String subst = "year: $1, month: $2, day: $3, hours: $4, minutes: $5, seconds: $6$7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}