// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9]\d*)-(0[1-9]|1[0-2])-(0?[1-9]|[1-2]\d|3[0-2])(?:\x20([01][0-9]|2[0-3]):([0-5]\d):([0-5]\d)(\.\d+)?)?$").unwrap();
let string = "2015-03-32 07:00:00
2015-05-15 12:00:54.02911";
let substitution = "year: $1, month: $2, day: $3, hours: $4, minutes: $5, seconds: $6$7";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}