#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Abonează-te\n)[\s\S]*?(?=\nAbonează-te)"
Local $sString = ""NU POSTA aÅŸa ceva pe Facebook! „Prostia se plăteÅŸteâ€" & @CRLF & _
"Publicat la: 10.02.2015 10:20 Ultima actualizare: 10.02.2015 10:35" & @CRLF & _
"Adresa de e-mail la care vrei sa primesti STIREA atunci cand se intampla" & @CRLF & _
"Abonează-te" & @CRLF & _
"---- Here is some usefull text --- " & @CRLF & _
"Abonează-te" & @CRLF & _
"× Citeşte mai mult »" & @CRLF & _
"Adauga un comentariu""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")