import re
regex = re.compile(r"(?<=Abonează-te\n)[\s\S]*?(?=\nAbonează-te)", flags=re.MULTILINE)
test_str = ("\"NU POSTA aÅŸa ceva pe Facebook! „Prostia se plăteÅŸteâ€\n"
"Publicat la: 10.02.2015 10:20 Ultima actualizare: 10.02.2015 10:35\n"
"Adresa de e-mail la care vrei sa primesti STIREA atunci cand se intampla\n"
"Abonează-te\n"
"---- Here is some usefull text --- \n"
"Abonează-te\n"
"× Citeşte mai mult »\n"
"Adauga un comentariu\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")