re = /(?<=Abonează-te\n)[\s\S]*?(?=\nAbonează-te)/m
str = '"NU POSTA aÅŸa ceva pe Facebook! „Prostia se plăteÅŸteâ€
Publicat la: 10.02.2015 10:20 Ultima actualizare: 10.02.2015 10:35
Adresa de e-mail la care vrei sa primesti STIREA atunci cand se intampla
Abonează-te
---- Here is some usefull text ---
Abonează-te
× Citeşte mai mult »
Adauga un comentariu"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end