#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)SMR_.*_(.*)_GRID_(?P<Model>[a-zA-Z]+)_.*"
Local $sString = "RV_Exp_CX_GRID_08OCT18.dat" & @CRLF & _
"RV_Exp_JT_GRID_07NOV18.dat" & @CRLF & _
"RV_Exp_OPEL_WB_GRID_21NOV18.dat" & @CRLF & _
"RV_Ref_U_GRID_07NOV18.dat" & @CRLF & _
"SMR_Exp_CX_GRID_D_11OCT18txt" & @CRLF & _
"SMR_Exp_CX_GRID_E_30JUL18txt" & @CRLF & _
"SMR_Exp_CX_GRID_JS_07AUG18txt" & @CRLF & _
"SMR_Exp_CX_GRID_JT_17SEP18txt" & @CRLF & _
"SMR_Exp_GRID_D_07NOV18txt" & @CRLF & _
"SMR_Exp_GRID_E_05OCT18txt" & @CRLF & _
"SMR_Exp_GRID_JS_08JAN19txt" & @CRLF & _
"SMR_Exp_GRID_JT_07NOV18txt" & @CRLF & _
"SMR_Ref_GRID_D_07NOV18txt" & @CRLF & _
"SMR_Ref_GRID_E_05OCT18txt" & @CRLF & _
"SMR_Ref_GRID_JS_08JAN19txt" & @CRLF & _
"SMR_Ref_GRID_JT_07NOV18txt" & @CRLF & _
"SMR_WB_Exp_GRID_D_14NOV18txt" & @CRLF & _
"SMR_WB_Exp_GRID_JS_20FEB19txt" & @CRLF & _
"SMR_WB_Exp_GRID_JT_14NOV18txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")