import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SMR_.*_(.*)_GRID_(?P<Model>[a-zA-Z]+)_.*";
final String string = "RV_Exp_CX_GRID_08OCT18.dat\n"
+ "RV_Exp_JT_GRID_07NOV18.dat\n"
+ "RV_Exp_OPEL_WB_GRID_21NOV18.dat\n"
+ "RV_Ref_U_GRID_07NOV18.dat\n"
+ "SMR_Exp_CX_GRID_D_11OCT18txt\n"
+ "SMR_Exp_CX_GRID_E_30JUL18txt\n"
+ "SMR_Exp_CX_GRID_JS_07AUG18txt\n"
+ "SMR_Exp_CX_GRID_JT_17SEP18txt\n"
+ "SMR_Exp_GRID_D_07NOV18txt\n"
+ "SMR_Exp_GRID_E_05OCT18txt\n"
+ "SMR_Exp_GRID_JS_08JAN19txt\n"
+ "SMR_Exp_GRID_JT_07NOV18txt\n"
+ "SMR_Ref_GRID_D_07NOV18txt\n"
+ "SMR_Ref_GRID_E_05OCT18txt\n"
+ "SMR_Ref_GRID_JS_08JAN19txt\n"
+ "SMR_Ref_GRID_JT_07NOV18txt\n"
+ "SMR_WB_Exp_GRID_D_14NOV18txt\n"
+ "SMR_WB_Exp_GRID_JS_20FEB19txt\n"
+ "SMR_WB_Exp_GRID_JT_14NOV18txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}