import re
regex = re.compile(r"SMR_.*_(.*)_GRID_(?P<Model>[a-zA-Z]+)_.*", flags=re.MULTILINE)
test_str = ("RV_Exp_CX_GRID_08OCT18.dat\n"
"RV_Exp_JT_GRID_07NOV18.dat\n"
"RV_Exp_OPEL_WB_GRID_21NOV18.dat\n"
"RV_Ref_U_GRID_07NOV18.dat\n"
"SMR_Exp_CX_GRID_D_11OCT18txt\n"
"SMR_Exp_CX_GRID_E_30JUL18txt\n"
"SMR_Exp_CX_GRID_JS_07AUG18txt\n"
"SMR_Exp_CX_GRID_JT_17SEP18txt\n"
"SMR_Exp_GRID_D_07NOV18txt\n"
"SMR_Exp_GRID_E_05OCT18txt\n"
"SMR_Exp_GRID_JS_08JAN19txt\n"
"SMR_Exp_GRID_JT_07NOV18txt\n"
"SMR_Ref_GRID_D_07NOV18txt\n"
"SMR_Ref_GRID_E_05OCT18txt\n"
"SMR_Ref_GRID_JS_08JAN19txt\n"
"SMR_Ref_GRID_JT_07NOV18txt\n"
"SMR_WB_Exp_GRID_D_14NOV18txt\n"
"SMR_WB_Exp_GRID_JS_20FEB19txt\n"
"SMR_WB_Exp_GRID_JT_14NOV18txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")