const regex = /\b[A-Za-z_]\w*(?=(?:(?!{{|}}).)*}})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Za-z_]\\w*(?=(?:(?!{{|}}).)*}})', 'gm')
const str = `Test Test2'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}