$re = '/\b[A-Za-z_]\w*(?=(?:(?!{{|}}).)*}})/m';
$str = 'Test Test2\'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);