re = /\b[A-Za-z_]\w*(?=(?:(?!{{|}}).)*}})/m
str = 'Test Test2\'{{TimeStamps(Descending(1))(7:8)}}/{{TimeStamps(Descending(1))(1:4)}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end