package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\((.+)\)\ ?\/\ ?\(((?:[^()]*?\([^()]*?\))*[^()]*?)\)`)
var str = `<p align="center">b<sub>я</sub> = ((230.79*10<sup>-6</sup>) + 10) / (5*(76)*10<sup>-3</sup> + 5) + 9 = <a id="bya" href="javascript:void(0)" onclick="Sheet.Refresh(this);">46.16</a>*10<sup>-3</sup><br><br></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}