$re = '/\((.+)\)\ ?\/\ ?\(((?:[^()]*?\([^()]*?\))*[^()]*?)\)/i';
$str = '<p align="center">b<sub>я</sub> = ((230.79*10<sup>-6</sup>) + 10) / (5*(76)*10<sup>-3</sup> + 5) + 9 = <a id="bya" href="javascript:void(0)" onclick="Sheet.Refresh(this);">46.16</a>*10<sup>-3</sup><br><br></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);