import Foundation
let pattern = #"\((.+)\)\ ?\/\ ?\(((?:[^()]*?\([^()]*?\))*[^()]*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<p align="center">b<sub>я</sub> = ((230.79*10<sup>-6</sup>) + 10) / (5*(76)*10<sup>-3</sup> + 5) + 9 = <a id="bya" href="javascript:void(0)" onclick="Sheet.Refresh(this);">46.16</a>*10<sup>-3</sup><br><br></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)