using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$";
string substitution = @"";
string input = @"VIR RECU 998721687978
DE: Mrs PAUL SMITH
564
MOTIF: ANY REASON";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}