import Foundation
let pattern = #"^VIR\s+RECU\s+(\d+)\nDE:\s+([\s\S]*?)(\nMOTIF:\s+(.*))?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
VIR RECU 998721687978
DE: Mrs PAUL SMITH
564
MOTIF: ANY REASON
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)