import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^VIR\\s+RECU\\s+(\\d+)\\nDE:\\s+([\\s\\S]*?)(\\nMOTIF:\\s+(.*))?$";
final String string = "VIR RECU 998721687978\n"
+ "DE: Mrs PAUL SMITH\n"
+ "564\n"
+ "MOTIF: ANY REASON";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}