#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^\S+\s+(\d{2})?(\d{2})\s*(?:[-_]|to)\s*(present|\S+)\s*(\d{2})?(\d{2})?$"
Local $sString = "February 2016 - March 2019" & @CRLF & _
"September 2015 to August 2019" & @CRLF & _
"April 2015 to present" & @CRLF & _
"September 2018 - present" & @CRLF & _
"Feb. 2016 - March 2019" & @CRLF & _
"Sept 2015 to Aug. 2019" & @CRLF & _
"April 2015 to present" & @CRLF & _
"Nov. 2018 - present" & @CRLF & _
"" & @CRLF & _
"Invalid string:" & @CRLF & _
"George Mason University august 2019" & @CRLF & _
"" & @CRLF & _
"Stratusburg university February 2018" & @CRLF & _
"" & @CRLF & _
"Some text and month followed by year"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")