import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^\\S+\\s+(\\d{2})?(\\d{2})\\s*(?:[-_]|to)\\s*(present|\\S+)\\s*(\\d{2})?(\\d{2})?$";
final String string = "February 2016 - March 2019\n"
+ "September 2015 to August 2019\n"
+ "April 2015 to present\n"
+ "September 2018 - present\n"
+ "Feb. 2016 - March 2019\n"
+ "Sept 2015 to Aug. 2019\n"
+ "April 2015 to present\n"
+ "Nov. 2018 - present\n\n"
+ "Invalid string:\n"
+ "George Mason University august 2019\n\n"
+ "Stratusburg university February 2018\n\n"
+ "Some text and month followed by year";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}