# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)^\S+\s+(\d{2})?(\d{2})\s*(?:[-_]|to)\s*(present|\S+)\s*(\d{2})?(\d{2})?$"
test_str = ("February 2016 - March 2019\n"
"September 2015 to August 2019\n"
"April 2015 to present\n"
"September 2018 - present\n"
"Feb. 2016 - March 2019\n"
"Sept 2015 to Aug. 2019\n"
"April 2015 to present\n"
"Nov. 2018 - present\n\n"
"Invalid string:\n"
"George Mason University august 2019\n\n"
"Stratusburg university February 2018\n\n"
"Some text and month followed by year")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.