package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+$`)
var str = `456564
4566 456546
4545h54
hhhhh
355634546546`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}