const regex = /^\d+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+$', 'mg')
const str = `456564
4566 456546
4545h54
hhhhh
355634546546`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}