#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=/)([0-9]{1,2})[*]*([GM])[+]?(\1[*]*\2[+]?)+"
Local $sString = "AA/8G+8G+8G+8G/WITHOUT *" & @CRLF & _
"AA/8*G+8*G+8*G+8*G/WITH *" & @CRLF & _
"AA/8G+8*G+8*G+8*G/MIXED, THIS IS NOT SUPPORTED YET" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")